Instalacja PODbotow

Oficjalna strona podbotów
Dlaczego podboty a nie zboty ? Zboty nie działają zbyt dobrze w połączeniu z amxx’em dlatego lepiej używać podbotów

Instalacja:

  1. Ściągamy ten plik podbot.zip jest to najnowsza wersja podbotow w języku polskim
  2. Rozpakowujemy archiwum , folder podbots kopiujemy do cstrike/addons/
  3. Edytujemy teraz plik plugins.ini znajdujący się w cstrike/addons/metamod/
  4. Na końcu w nowej linijce dopisujemy
    • Dla windows :
      win32 addons/podbot/podbot_mm.dll
    • Dla linux:
      linux addons/podbot/podbot_mm_i386.so
  5. Zapisujemy zmiany

Aby móc używać menu podbotów musimy ustawić odpowiednie hasło u siebie i na serwerze
w podbot.cfg znajdujemy

pb_passwordkey "_pbadminpw"

nie musimy tego zmieniać hasło ustawiamy gdzie indziej ale możemy tutaj ustawić jakiego keya będzie pobierana wartość
hasło ustawiamy tutaj

pb_password "your_password"

gdy ustalimy hasło musimy dopisać je do naszego config.cfg
szablon to

setinfo "_pbadminpw" "your_password"

_pbadminpw to to co ustawimy w pb_passwordkey a your_password to hasło ustawione w pb_password

jeszcze tylko robimy sobie binda do otwieranie menu podobotów np. na klawisz ‚=’

bind "=" "pb menu"

dopisujemy do config.cfg i podboty są gotowe do działania

Podstawowe komendy podbotów

73 komentarzy o “Instalacja PODbotow

  1. zrobiłem wszystko jak trzeba i jak wcisne w grze „=” nie działa menu a jak w konsoli (~) napiszę bind „=” pb menu wyskakuje :
    ] bind = pb menu
    bind [command] : attach a command to a k

  2. a może to dlatego. W folderze podbotów gdy chce wstawić tam te 2 pliki na server pisze:

    Plik podbot_mm_amd64.so jest zbyt duży. Ten plik nie może być pobrany.
    Plik podbot_mm_i386.so jest zbyt duży. Ten plik nie może być pobrany.

  3. DarkGl pomuż zrobilem wszystko tak jak pisales ale wbijam na serva niema botów i jak klikam = wyskakuje Unknown command: pb

  4. mam problem nie moge połapać się z tym hasłem tam gdzie jest pb_password „your_password” wpisałem hasło lecz menu nie działa binda też zrobiłem i nie działa nie wiem dla czego prosze o pomoc .

  5. Siemka dziś zainstalowałem sobie na serwer podboty niestety nie działają one jak trzeba…
    Wszystko działa oprócz tego, że co 1 sek jakiś bot wychodzi z serwera a na jego miejsce wchodzi bot pod innym nickiem… i tak cały czas
    Jak to naprawić??

  6. Mam pytanie
    1.Czy trzeba robic Waypionty?
    2.czy te boty obciazaja strasznie serwer
    3.Czy da sie zrobic aby boty wychodzily jak gracz wejdzie?
    Z gory dzieki

  7. Dark, tez mam ten je*any problem z tym „Nieznana komenda: pb” instalowalem to 2 razy, zgodnie z twoim poradnikiem krok po kroku i dalej to samo.. moze to zalezy od jakis plikow? Nie znam sie na tym duzo, prosze o odp ;p

  8. Nazwy botów zmieniasz w ich pliku konfiguracyjnym ( cfg ) jest on w głównym folderze botów.

    Być może mod paintball nie jest z nimi kompatybilny.

    1. DarkGL – Powiem szczerze że wgrałem kiedyś te PodBoty na mod paintball i są w 100% nie skuteczne ponieważ możesz kole botów normalnie przechodzić i cie nie zabijają 🙁
      Więc na PaintBall te boty odpadają w 100%

  9. Witam.
    Widzę że dużo użytkowników ma problem z podbotami 🙂
    Też tak kiedyś miałem ale sobie poradziłem ponieważ wyraźnie jest napisane żeby sie podboty przyłączały na serwer trzeba wpisać hasło botów jakie macie ustawione w cfg botów
    I kolejne co najważniejsze podboty nie są pod amxmodx tylko pod metamod’a czyli że jak będziecie chcieli dodać boty to nic wam nie da zmiana mapy ponieważ system metamod sie nie zalicza do zmiany mapy tylko amxmodx zawsze wczyta nowe fukcje ale z metamod’a nic wam nie wczyta, żeby temu zapobiec wystarczy wszystko wykonać tak jak piszę u góry i nie zmieniać mapy tylko wyłączyć i włączyć serwer 🙂 a jeśli dalej by nie działo bo ktoś jeszcze zapomniał czegoś zrobić to nie róbcie tak że poprawicie błąd wbijecie na serw i będziecie myśleć ze już jest wszystko ok lub że zmienicie mape i będzie ok nie! zawsze paczcie jak wyłączycie i włączycie serwer tak samo jak coś zmieniacie w cfg podbotów to też do puki serwer nie będzie zresetowany to tych zmień nie zobaczycie 🙂
    Dodam jeszcze że podboty będą tylko na tym mapach co są takie pliki w folderze pod botów folder o nazwie „wptdefault” jeśli w tym folderze nie będzie pliku od danej mapy to botów na tej mapie nie zobaczycie.

    Myślę że pomogłem 🙂

    Pozdrawiam Mr.Skull [t]

  10. nie działa mi bind, nic sie nie wyswietla chociaz dodalem wszystko po kolei wg instrukcji i resnalem serwa.
    boty dzialaja, nicki itp ale „=” nie diala.

  11. Czy da się zwiększyć ilość way point’ów do postawienia na mapie ? Bo u mnie jest max 1024 :/ a mapa jest stosunkowo duża.

  12. Mam pytanie jak zrobić żeby na serwie siedzialy 4 boty na początku a nie 3? Jak wchodzę na serwer usuwa sie jeden bot, a jak kolega to drugi i zostaje tylko 1. A moje pytanie jest takie jak zrobic zeby był jeszcze 1 dodatkowy bot (przez komende pb menu nie dodaje sie bot)

  13. [POD]Polymorph (99) connected
    [POD]Polymorph (99) has left the game
    [P0D]Fuzzy Logic (98) connected
    [P0D]Fuzzy Logic (98) has left the game
    [P0D]Burt_Reynolds (96) connected
    [P0D]Burt_Reynolds (96) has left the game
    [P*D]Dr. No (97) connected
    [P*D]Dr. No (97) has left the game
    [P0D]Woody_Harrelson (98) connected
    [P0D]Woody_Harrelson (98) has left the game

    Dlaczego tak jest?

  14. DarkGL ratuj, dodaje mi 3 boty normalnie bez skazy komenda „rcon pb add” a jak nastepego dodaje i on chce wejsc to sie nie da i co chwila jest tylko bot left bot connect bot left ze SPECTa oczywiscie, co ja moge zrobic co mi moze blokowac?

    // bots
    bot_quota 0
    bot_quota_mode fill
    bot_difficulty 3
    bot_chatter on
    bot_auto_follow 1
    bot_auto_vacate 1
    bot_join_after_player 1
    bot_defer_to_human 0
    bot_allow_rogues 0
    bot_walk 0
    bot_join_team any
    bot_eco_limit 2000
    bot_allow_grenades 1
    bot_all_weapons
    bot_allow_grenades 1
    bot_allow_pistols 1
    bot_allow_sub_machine_guns 1
    bot_allow_shotguns 1
    bot_allow_rifles 1
    bot_allow_snipers 1
    bot_allow_machine_guns

    to z pliku serwer.cfg

  15. Jest sposób by wgrać boty na CodMod 201? Próbowałem jak tu jest napisane, ale jedynie to działały boty, admin i serwer już nie

Dodaj komentarz